Où sommes nous ?

Mise a jour d'Apache vers la version 2.4.x

Aujourd'hui, mise-à-jour routinière du système qui provoque entre autre le passage d'Apache 2.2.31 vers la versions 2.4.18 ... ce qui a créé un gros binse sur mon site web.

Ajout de modules nécessaires

Certaines directives ont disparu ou sont passées dans des modules devenus optionnels. Il est donc nécessaire de rajouter les modules unixd et authz_core dans le APACHE2_MODULES="" du fichier /etc/portage/make.conf.

Il faut aussi ajouter les lignes suivantes dans le fichier /etc/apache2/httpd.conf

LoadModule unixd_module modules/mod_unixd.so
LoadModule authz_core_module modules/mod_authz_core.so

Certaines directives ont changé

Les directives Allow et Deny sont dépréciées : il faut les remplacer comme suit

Order deny,allow
Deny from all

devient

Require all denied
Order allow,deny
Allow from all

devient

Require all granted

enfin, plus compliqué

Order Deny,Allow
Deny from all
Allow from ma_machine ::1 192.168.0.2

devient alors

<RequireAny>
Require host ma_machine
Require ip 192.168.0.2
Require ip ::1
</RequireAny>

Visitez :
La liste de nos voyages
Nos sorties Ski et rando
Copyright Laurent Faillie 2001-2017
N'oubliez pas d'entrer le mot de passe pour voir aussi les photos perso.
Contactez moi si vous souhaitez réutiliser ces photos et pour les obtenir avec une plus grande résolution.
Visites durant les 7 derniers jours Nombre de visites au total.

Vous pouvez laissez un commentaire sur cette page.